Back to overview
Maintenance
Tropica Update
Jan 03 at 10:24am HST
–
Jan 03 at 11:15am HST
Affected services
Tropica
Tropica Database
Resolved
Jan 03 at 11:15am HST
Update succesfull! Have a wonderfull 2026!
Affected services
Updated
Jan 03 at 11:02am HST
The update was executed succesfully! We'll be monitoring Tropica for the next hour for any abnormalities.
The maintenance will be lifted after this period of time. For now stay Tropical!
Affected services
Created
Jan 03 at 10:24am HST
We're currently updating Tropica to a new type of system. Henceforth the downtime could be longer then expected.
Affected services